Posts Tagged ‘multiple site bindings’

Hello everyone

After investigating for about a week on an issue, I’m here to summerize and give you information about it.

Our platfrom is SharePoint 2013 and using office 2013 client applications. We have a root site collection and couple of host named site collections also.

If you need to use people and group fields in Document Infomation Panel or as people picker in InfoPath forms, maybe you have seen that your InfoPath form or Word document stops working and it may hang or carsh.

By searching internet you will come up with some ideas that you should modify the web.config file and set attribute MultipleSiteBindingEnabled to True.

Something like this:


<system.serviceModel>
<serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
</system.serviceModel>

However I found that this modification could have lots of annoying side effects and is not working properly. Although depends on your configuration. I recommend don’t do it!  It can cause the drag and drop functionality on document libraries stop working, it can cause the internal people and group fields (for example for lists) stop searching the directory and it can cause SharePoint designer to not be able to connect to your sites.

What I found instead was quite simple suprisingly. We had used manully binding into IIS which I found is not correct. To summerize and cut a long story short, I found:

  1. There is no need to modify the web.config file for adding multiple site bindings attribute
  2. And more importantly never ever manually add site binding into the IIS console

 

Just following this two instructions everything works like a charm in our farm.

Hope this helps.

Navid 🙂

 

 

 

Advertisements